We are continuing to work on a fix for this issue.
Posted Feb 17, 2026 - 18:28 CET
Update
Customers using Personio Payroll are not impacted by this partial disruption anymore. We are working on a solution for customers using the DATEV-Integration. We will keep you updated here.
Posted Feb 17, 2026 - 18:16 CET
Update
We have temporarily blocked the approval of the payroll while we are working on fully resolving this partial disruption. Update: Our Personio Payroll customers can approve the payroll as usual again.
Posted Feb 17, 2026 - 13:34 CET
Identified
We are currently experiencing some issues with the module Payroll.
Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.
We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Feb 17, 2026 - 12:48 CET
This incident affects: Overall System availability and Payroll (Personio Payroll DE).