Partial service disruption: Personio Payroll

Incident Report for Personio SE & Co. KG

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 18:08 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 14:38 CET

Identified

We identified the root cause and are working on a solution.
Posted Mar 20, 2025 - 10:30 CET

Investigating

We identified an issue where new Payroll Tax Changes from January onwards are not working as expected. The Approval button is disabled until we can ensure the data is correct.
Posted Mar 20, 2025 - 10:00 CET
This incident affected: Personio Payroll DE.