We are continuing to monitor for any further issues.
Posted Sep 11, 2025 - 15:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2025 - 13:58 CEST
Investigating
We are having intermittent issues in the employee performance area, user actions might be executed with a delay. No data loss is involved Our engineering teams are already working on a solution.
We will keep you posted with the latest information and apologize for any inconvenience this may caused.