The system is stable again. We apologize for any inconvenience caused!
Posted Jun 30, 2026 - 15:47 CEST
Investigating
We are currently experiencing a full service disruption. Our engineering team is already investigating the cause and we will keep you posted. We apologize for any inconvenience caused!
Posted Jun 30, 2026 - 14:54 CEST
This incident affected: Overall System availability and Core Platform (Public API, Support & Help, Analytics, Company Configuration, Documents & E-Signatures, Employee & Organization Management, Home & Inbox, Personio built Integrations & Marketplace, Login & Authentication, Mobile App, Salary Management, Time Management (Time Tracking, Time-off, Overtime), Workflows & Automations).