Referral page not working correctly

Incident Report for Personio Statuspage

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 16:12 CEST

Investigating

The referral page within Recruiting is not working correctly. The team is investigating.
Posted Jul 30, 2026 - 16:04 CEST
This incident affected: Apps (Recruiting).