Partial service disruption | Emails for security token and password reset mails delayed

Incident Report for Personio SE & Co. KG

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 15:21 CEST

Identified

We are currently experiencing some issues with the mailing module. Security Mails and Password Reset Mails might delay a bit.

Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.

We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Apr 23, 2025 - 15:02 CEST
This incident affected: Email services.