The implemented fix is working as expected and the issue is fully resolved. We apologize for any inconvenience this may have caused. Thanks for your understanding!
Posted Sep 09, 2025 - 10:01 CEST
Monitoring
A fix has been implemented and access to Personio is be possible again. Our engineers are monitoring the systems to ensure the issues is fully resolved.
Posted Sep 09, 2025 - 09:48 CEST
Investigating
Our system is currently not available due to a global service outage. You may encounter HTTP 504 or 404 errors when trying to access Personio. Engineers are already working to get everything up and running again.
We will keep you posted with the latest information and apologize for any inconvenience this may cause.