Partial service disruption

Incident Report for Personio Statuspage

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 17:02 CET

Monitoring

A fix has been implemented. Our engineers are monitoring the systems to ensure the issues is fully resolved.
Posted Feb 17, 2026 - 15:22 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 17, 2026 - 14:16 CET

Investigating

We are currently experiencing some issues with the module Notifications / Inbox. Workflow notification tasks and respective notification emails have missing information.

Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already investigating.

We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Feb 17, 2026 - 12:57 CET