Changes delayed in Payroll
Incident Report for
Personio Statuspage
Resolved
This incident has been resolved and the system is stable.
Posted
Sep
14
,
2026
-
11:02
CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Sep
14
,
2026
-
10:46
CEST
Investigating
We are currently investigating a delay in data changes. Premium manual and automatic generations might be delayed for Personio Payroll.
Posted
Sep
14
,
2026
-
10:17
CEST
This incident affected: Payroll (Personio Payroll DE).
×
Subscribe to Incident
Subscribe to updates for
Changes delayed in Payroll
via . You'll receive .