Partial service disruption

Incident Report for Personio Statuspage

Identified

We identified an issue affecting the creation of some Microsoft Teams video conferencing links for scheduled interviews. We’re working with our 3rd party vendor to resolve the issue. Thank you for your continued patience.
Posted Feb 11, 2026 - 15:58 CET

Investigating

We are currently experiencing some issues with the Recruiting App. The following features are affected:
- Meeting links for Microsoft Teams are not generating when planning an interview

Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.

We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Feb 10, 2026 - 17:12 CET
This incident affects: Overall System availability.