The outage affecting access to Personio has been fully resolved. All services are operating normally.
Thank you for your patience while we worked through this.
Posted May 06, 2026 - 09:20 CEST
Update
We are continuing to monitor for any further issues.
Posted May 06, 2026 - 09:06 CEST
Monitoring
Personio is loading again and account access has been restored. We're monitoring the service closely to confirm full stability.
We'll post the next update by 9:30 CEST.
Posted May 06, 2026 - 09:06 CEST
Update
We've identified the cause of the outage affecting access to Personio. Our engineering team is working on the fix now.
We'll post the next update by 9:15 CEST.
Posted May 06, 2026 - 09:02 CEST
Investigating
We're investigating a global outage affecting access to Personio. Customers are currently not able to load the application or reach their accounts.
Our engineering team is actively working on this and it's our top priority. We'll post the next update by 9:00 am CEST, whether or not we have new information to share.
Posted May 06, 2026 - 08:38 CEST
This incident affected: Overall System availability.