The implemented fix is working as expected and the issue is fully resolved. We apologize for any inconvenience this may have caused. Thanks for your understanding!
Posted Dec 16, 2025 - 17:56 CET
Monitoring
A fix has been implemented. Our engineers are monitoring the systems to ensure the issues is fully resolved.
Posted Dec 16, 2025 - 17:45 CET
Investigating
We are currently experiencing some issues with Personio Payroll. The following features are affected: - Due to internal technical reasons approval is blocked for some customers, we are working on getting them unblocked shortly
Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.
We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Dec 16, 2025 - 16:32 CET
This incident affected: Overall System availability and Payroll (Personio Payroll DE).