Sending of emails in Recruiting

Incident Report for Personio Statuspage

Resolved

The implemented fix is working as expected and the issue is fully resolved. We apologize for any inconvenience this may have caused. Thank you for your understanding!
Posted Mar 27, 2026 - 13:25 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 19:07 CET

Investigating

There are still issues with the sending of messages to candidates. Recruiting emails will be delayed while we investigate this.
Posted Mar 26, 2026 - 15:49 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 10:36 CET

Investigating

We are still experiencing issues with the sending of emails to candidates in Recruiting. The team is investigating.
Posted Mar 26, 2026 - 09:08 CET
This incident affected: Apps (Recruiting).