Time Tracking

Incident Report for Personio SE & Co. KG

Resolved

This incident has been resolved.
- All attendance periods have been restored.
- Overtime balance has been re-calculated.
- Approval requests that refer to outdated attendance periods have been cleaned up.
Posted Mar 17, 2025 - 19:14 CET

Update

We have fixed the issue of the approvals not working as expected in some cases.

We are continuing the re-calculation of overtime balances for some edge cases and will provide an update once we have finished this.
Posted Mar 17, 2025 - 18:19 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2025 - 14:06 CET

Investigating

After last week's incident regarding time tracking, we continue to cleanup the side effects. We are currently investigating an issue where users might experience errors when trying to approve time tracking submissions.
Posted Mar 17, 2025 - 11:46 CET
This incident affected: System availability.