Partial service disruption

Incident Report for Personio Statuspage

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 13:05 CEST

Investigating

We are currently experiencing some issues with the personal absence page not loading correctly. We are investigating the issue.
Posted Aug 05, 2025 - 12:59 CEST