Partial service disruption - Time Tracking

Incident Report for Personio SE & Co. KG

Resolved

All data has been completely restored and overtime and deficit hours have been recalculated.
Posted Mar 15, 2025 - 11:43 CET

Monitoring

Some parts of the issue have been fully resolved, but work is still ongoing to restore missing attendance data.

- Attendance periods related to integrations have been restored.
- Overtime and deficit hours have been recalculated.

Our team is continuing to address the remaining impact, and we will provide further updates as progress is made.

Thank you for your patience!
Posted Mar 14, 2025 - 15:51 CET

Update

We are still working on restoring all affected data and fully resolving the issue. Our team is making progress, and we will provide further updates as soon as possible.

Thank you for your patience!
Posted Mar 14, 2025 - 14:21 CET

Identified

We have identified the issue and are actively working on restoring affected data.

Current progress:
- Incorrect clock-out related attendance periods have been restored
- Overtime balances are being recalculated
- Attendance data related to integrations is being restored

We will provide further updates as the recovery progresses. Thank you for your patience!
Posted Mar 14, 2025 - 13:17 CET

Investigating

We are currently investigating an issue affecting the Time Tracking feature, which may impact tracked times and overtime balances. Our team is working to identify the root cause and and will provide updates as soon as possible.

Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.

We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Mar 14, 2025 - 09:32 CET
This incident affected: System availability.