The implemented fix is working as expected and the issue is fully resolved. Additionally, all pending invitation emails have been re-sent. We apologize for any inconvenience this may have caused. Thanks for your understanding!
Posted Mar 06, 2026 - 10:09 CET
Monitoring
A fix has been implemented. Our engineers are monitoring the systems to ensure the issues is fully resolved.
Posted Mar 05, 2026 - 15:19 CET
Identified
The issue has been identified. A fix is being currently implemented.
Posted Mar 05, 2026 - 14:27 CET
Investigating
We are currently experiencing some issues with inviting employees. The following features are affected: - New employees created via the employee list might not receive an invitation email
Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.
We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Mar 04, 2026 - 14:00 CET
This incident affected: Overall System availability and Core Platform (Login & Authentication).