Payroll is not loading

Incident Report for Personio Statuspage

Resolved

This incident has been resolved, the Payroll is operational again. We apologize for any inconvenience caused!
Posted Jun 16, 2026 - 19:38 CEST

Investigating

Currently the Payroll feature is not loading and not accessible. Our Engineering team is already investigating and working on resolving this issue as quickly as possible.
Posted Jun 16, 2026 - 17:52 CEST
This incident affected: Payroll (Personio Payroll DE, Preliminary Payroll (and file export integrations), Datev Integration, Xero Integration, A3 Integration, Loket Integration, Tax Advisor Platform).